Sometimes, needed to be alone to feel passionately.
 

$ lsusb
Bus 004 Device 001: ID 0000:0000
Bus 005 Device 003: ID 0421:04f9 Nokia Mobile Phones
Bus 005 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000

Notice the ID 0421:04f9 Nokia Mobile Phones. Here 0421 is the vendor id and 04f9 is the product id.

$ sudo modprobe usbserial vendor=0x0421 product=0x04f9

$ wvdialconf create
Editing `create'.

Scanning your serial ports for a modem.

WvModem<*1>: Cannot set information for serial port.
ttyS0<*1>: ATQ0 V1 E1 -- failed with 2400 baud, next try: 9600 baud
ttyS0<*1>: ATQ0 V1 E1 -- failed with 9600 baud, next try: 115200 baud
ttyS0<*1>: ATQ0 V1 E1 -- and failed too at 115200, giving up.
Modem Port Scan<*1>: S1 S2 S3
WvModem<*1>: Cannot get information for serial port.
ttyACM0<*1>: ATQ0 V1 E1 -- OK
ttyACM0<*1>: ATQ0 V1 E1 Z -- OK
ttyACM0<*1>: ATQ0 V1 E1 S0=0 -- OK
ttyACM0<*1>: ATQ0 V1 E1 S0=0 &C1 -- OK
ttyACM0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 -- OK
ttyACM0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
ttyACM0<*1>: Modem Identifier: ATI -- Nokia
ttyACM0<*1>: Speed 4800: AT -- OK
ttyACM0<*1>: Speed 9600: AT -- OK
ttyACM0<*1>: Speed 19200: AT -- OK
ttyACM0<*1>: Speed 38400: AT -- OK
ttyACM0<*1>: Speed 57600: AT -- OK
ttyACM0<*1>: Speed 115200: AT -- OK
ttyACM0<*1>: Speed 230400: AT -- OK
ttyACM0<*1>: Speed 460800: AT -- OK
ttyACM0<*1>: Max speed is 460800; that should be safe.
ttyACM0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK

Found an USB modem on /dev/ttyACM0.
create: Can't open 'create' for reading: No such file or directory
create: ...starting with blank configuration.
Modem configuration written to create.
ttyACM0: Speed 460800; init "ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0"

$ sudo vi /etc/wvdial.conf

[Dialer Defaults]
Modem = /dev/ttyACM0
Baud = 460800
Init1 = AT&F
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
I
ISDN = 0
Modem Type = Nokia GSM Phone USB Modem
Phone = *99#
Username = any
Password = any
Stupid Mode = 1

$ sudo wvdial
--> WvDial: Internet dialer version 1.56
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: AT&F
OK
--> Sending: AT E0 V1 &D2 &C1 &S0 S0=0 +dr=1
AT E0 V1 &D2 &C1 &S0 S0=0 +dr=1
OK
--> Sending: AT+IFC=2,2;+CVHU=1
OK
--> Sending: ATS7=60+DS=3,0;&K3
OK
--> Sending: AT+CGDCONT=,,"gpinternet"
OK
--> Sending: ATS0=0
OK
--> Modem initialized.
--> Sending: ATDT*99#
--> Waiting for carrier.
CONNECT
~[7f]}#@!}!} } }2}#}$@#}!}$}&percnt;\}"}&} }*} } g}&percnt;~
--> Carrier detected. Starting PPP immediately.
--> Starting pppd at Sat Jul 14 10:37:55 2007
--> Pid of pppd: 8383
--> Using interface ppp0
--> pppd: H[18]
--> [06][08][10][12][06][08]
--> pppd: H[18]
--> [06][08][10][12][06][08]
--> pppd: H[18]
--> [06][08][10][12][06][08]
--> pppd: H[18]
--> [06][08][10][12][06][08]
--> local IP address 10.130.9.55
--> pppd: H[18]
--> [06][08][10][12][06][08]
--> remote IP address 10.6.6.6
--> pppd: H[18]
--> [06][08][10][12][06][08]
--> primary DNS address 202.56.4.120
--> pppd: H[18]
--> [06][08][10][12][06][08]
--> secondary DNS address 202.56.4.121
--> pppd: H[18]
--> [06][08][10][12][06][08]


 


Comments

Fri, 30 Apr 2010 00:03:30

Nice info.

Thanks

 



Leave a Reply


Every thing is getting new look, I will make some new look.